ts-jestを使う時に、jestのバージョンで警告が出る

Nuxt

ts-jestを使う時に、jestのバージョンで警告が出た

ts-jestを使ってテストを書く際に、jestのバージョンで警告が出ましたので、その時の備忘録になります。

発生した警告

ts-jest[versions] (WARN) Version 24.9.0 of jest installed has not been tested with ts-jest. If you're experiencing issues, consider using a supported version (>=25.0.0 <26.0.0). 
Please do not report issues in ts-jest if you are using unsupported versions.
 PASS  test/unit/components/Something.spec.ts

対処方法

対処方法は、警告メッセージに出ていた通り、jestのバージョンを上げれば解決しました!

以下のように、yarn upgradejestをアップグレードすれば完了です!

$ yarn upgrade jest@^25.0.0

yarn upgradeについては、こちらの公式サイトをチェックしてください!

まとめ

今回は、ts-jestを使う時に、jestのバージョンで警告が出た際の対処方法について書きました!

yarn upgradeを使えば簡単に対処できるので、是非覚えておきたいですね!

Note一覧

コメント