【React/Vue】パッケージの依存性問題でエラーが出て起動しなくなった時

React

パッケージの依存性の問題でエラーが出て起動しなくなった

時々NPMのパッケージが廃止されたり、脆弱性のために更新されて、ReactVueなどの起動時に以下のような警告が表示されるようになります。

警告文に記載の通り、yarn upgradeを使用してアップグレードしたら、React/Vueが起動しなくなったので、備忘録として記載しておきます!

 WARN  Browserslist: caniuse-lite is outdated. Please run the following command: yarn upgrade

エラー内容

以下のように依存性問題でエラーが発生し、ReactやVueが起動できなくなる or 起動時に警告が出るようになりました。

$ yarn start
yarn run v1.19.0
$ PORT=4000 react-scripts start

There might be a problem with the project dependency tree.
It is likely not a bug in Create React App, but something you need to fix locally.

The react-scripts package provided by Create React App requires a dependency:

  "babel-loader": "8.0.6"

Don't try to install it manually: your package manager does it automatically.
However, a different version of babel-loader was detected higher up in the tree:

  /Users/kou/Desktop/awesome/node_modules/babel-loader (version: 8.1.0) 

Manually installing incompatible versions is known to cause hard-to-debug issues.

If you would prefer to ignore this check, add SKIP_PREFLIGHT_CHECK=true to an .env file in your project.
That will permanently disable this message but you might encounter other issues.

To fix the dependency tree, try following the steps below in the exact order:

  1. Delete package-lock.json (not package.json!) and/or yarn.lock in your project folder.
  2. Delete node_modules in your project folder.
  3. Remove "babel-loader" from dependencies and/or devDependencies in the package.json file in your project folder.
  4. Run npm install or yarn, depending on the package manager you use.

In most cases, this should be enough to fix the problem.
If this has not helped, there are a few other things you can try:

  5. If you used npm, install yarn (http://yarnpkg.com/) and repeat the above steps with it instead.
     This may help because npm has known issues with package hoisting which may get resolved in future versions.

  6. Check if /Users/kou/Desktop/awesome/node_modules/babel-loader is outside your project directory.
     For example, you might have accidentally installed something in your home folder.

  7. Try running npm ls babel-loader in your project folder.
     This will tell you which other package (apart from the expected react-scripts) installed babel-loader.

If nothing else helps, add SKIP_PREFLIGHT_CHECK=true to an .env file in your project.
That would permanently disable this preflight check in case you want to proceed anyway.

P.S. We know this message is long but please read the steps above :-) We hope you find them helpful!

error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

解決方法

本来は個別に依存性問題を解決して行くのが良さそうですが、一個直すとまた別のエラーが出て・・・みたい感じで結構カオスな感じでキツそうでした・・・!

とりあえず、解決方法として$ yarn upgrade –latestで全部最新にしちゃうとラクでした!

$ yarn upgrade --latest

ただし、当然のことながら全部アップグレードされちゃうので、注意してくださいね!w

業務などで、パッケージを全部アップグレードしちゃうのは危険なのでやめましょう・・!

個人プロジェクトならできるだけ最新に保っておきたいので、むしろ都合がいいですね!

個別のエラー修正

$ yarn startをすると、まだ依存性の問題が出ることがありました!

その時はエラーメッセージにしたがって個別に対応するしかありません!

Jestでのエラー例

react-scriptsで以下のバージョンのJestが必要とのこと。

There might be a problem with the project dependency tree.
It is likely not a bug in Create React App, but something you need to fix locally.

The react-scripts package provided by Create React App requires a dependency:

  "jest": "24.9.0"

$ yarn upgrade –latestで、以下のバージョンになっていたので、これを“jest”: “24.9.0”に修正してあげれば治りました!

package.json

    "jest": "^26.4.2",

Reactの起動

$ yarn startを実行して、エラーや警告なく起動できなくなればOKです!

$ yarn start

まとめ

今回は、ReactやVueでパッケージの依存性問題でエラーが出て起動しなくなった時の対処方法を紹介しました。

ちょっと荒技感はありますが、フロントエンドの依存性の闇は深いので、どうしても困った方は参考にしてみてくださいね!

オススメの関連商品

Note一覧

コメント